PAGO CAIDO

Incident Report for Helipagos

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 14:23 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Mar 04, 2026 - 14:22 GMT-03:00
This incident affected: Dashboards (clientes Sandbox).